News: Added Links For Twin Commander and Facebook Pages

Login  |  Register

Author Topic: More Hydraulic Questions- Flaps/Main LG  (Read 350 times)

Hamertime614

  • Newbie
  • *
  • Posts: 23
More Hydraulic Questions- Flaps/Main LG
« on: February 27, 2019, 06:50:52 pm »
On my 500A when the aux and engine hydraulic pumps are running the Hyd pressure never settles at 500/1000 respectively. The gauge is constantly wobbling between 450-500 on the electric and 950-1000 when the engines are running. Also when we did the gear swing the right gear began to drop after a few minutes and the flaps slowly go to full deflection. This is again ONLY on the right MLG side but both sides on the flap droops. Any Ideas would be greatly appreciated.

Adam Frisch

  • Administrator
  • Hero Member
  • *****
  • Posts: 1229
    • Adam Frisch FSF
Re: More Hydraulic Questions- Flaps/Main LG
« Reply #1 on: February 27, 2019, 08:16:03 pm »
It's so long ago and I'm going from memory, but I think you have an accumulator that's bad or leaking (or just needs to nitro up). Seem to recall you get low, unstable pressures when that's the problem.
Slumming it in the turboprop world - so you don't have to.

ghancock

  • Administrator
  • Hero Member
  • *****
  • Posts: 1110
Re: More Hydraulic Questions- Flaps/Main LG
« Reply #2 on: April 14, 2019, 08:34:12 am »
Adam is correct but it could also indicatea leak somewhere. There are lots of places that may be leaking and it only takes one to cause that.  if you canít find a leak check the accumulator pressure. It is in your left main gear well and has presure port at the bottom. fill with nitrogen.
--glenn
You can't win an argument with an ignorant person,  they'll just drag you down to their level and beat you with experience.

Bruce Byerly

  • Hero Member
  • *****
  • Posts: 586
Re: More Hydraulic Questions- Flaps/Main LG
« Reply #3 on: April 16, 2019, 12:12:11 am »
Check valve?